cPanel, Inc. has released EasyApache 3.26.2 with Apache version 2.4.10. This release addresses Apache vulnerabilities CVE-2014-0117, CVE-2014-0226, CVE-2014-0118, and CVE-2014-0231 by fixing bugs in the mod_proxy, mod_deflate, and mod_cgid modules. We encourage all Apache 2.4 users to upgrade to Apache version 2.4.10.
All versions of Apache 2.4 before 2.4.10.
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:
CVE-2014-0117 – MEDIUM
Fixed bug in the mod_proxy module related to CVE-2014-0117.
CVE-2014-0226 – MEDIUM
Fixed a race condition related to CVE-2014-0226.
CVE-2014-0118 – MEDIUM
Fixed bug in the mod_deflate module related to CVE-2014-0118.
CVE-2014-0231 – MEDIUM
Fixed bug in the mod_cgid module related to CVE-2014-0231.
cPanel, Inc. has released EasyApache 3.26.2 with an updated version of Apache 2.4 to correct these issues. Unless you have disabled EasyApache updates, EasyApache updates automatically. Run EasyApache to rebuild your profile with the latest version of Apache.
For the PGP-signed message, see ea 3-26-2 CVE-signed.