EasyApache 3.34.2 Release

cPanel, Inc. has released EasyApache 3.34.2 with Apache version 2.4.23 and patches to Apache 2.4 and 2.2 for the HTTPROXY vulnerability. This release addresses vulnerabilities related to CVE-2016-1546, CVE-2016-4979, and CVE-2016-5387. We strongly encourage all EasyApache users to update to version 3.34.2 and all Apache 2.4 users to upgrade to version 2.4.23.


All versions of EasyApache through version 3.34.1
All versions of Apache 2.4 through version 2.4.20
All versions of Apache 2.2 through version 2.2.31

The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2016-1546 – Medium
Apache 2.4.20
Fixed bug in mod_http2 related to CVE-2016-1546

CVE-2016-4979 – High
Apache 2.4.20
Fixed bug in mod_ssl related to CVE-2016-4979.

CVE-2016-5387 – HIGH
Apache 2.4
Patched Apache 2.4 for HTTPOXY vulnerability.

Apache 2.2
Patched Apache 2.2 for HTTPOXY vulnerability.

cPanel, Inc. has released EasyApache 3.34.2 with patches for Apache 2.4 and 2.2, and an updated version of Apache 2.4.23. Unless you have disabled EasyApache updates, the EasyApache application updates to the latest version when launched. Run EasyApache to rebuild your profile with the latest version of Apache.


For the PGP-signed message, please see EA 3-34-2 CVE